2018-07-20 17:35:06   

   tomcat yum 更新

#### 执行更新操作 ```bash yum update ``` ``` --> Finished Dependency Resolution Error: Package: ntp-4.2.6p5-25.el7.centos.2.x86_64 (@base) Requires: ntpdate = 4.2.6p5-25.el7.centos.2 Removing: ntpdate-4.2.6p5-25.el7.centos.2.x86_64 (@base) ntpdate = 4.2.6p5-25.el7.centos.2 Updated By: ntpdate-4.2.6p5-28.el7.centos.x86_64 (base) ntpdate = 4.2.6p5-28.el7.centos Error: Package: glibc-devel-2.17-196.el7.x86_64 (@base) Requires: glibc-headers = 2.17-196.el7 Removing: glibc-headers-2.17-196.el7.x86_64 (@base) glibc-headers = 2.17-196.el7 Updated By: glibc-headers-2.17-222.el7.x86_64 (base) glibc-headers = 2.17-222.el7 Error: Package: 1:grub2-tools-2.02-0.64.el7.centos.x86_64 (@anaconda) Requires: grub2-common = 1:2.02-0.64.el7.centos Installed: 1:grub2-common-2.02-0.65.el7.centos.2.noarch (@base) grub2-common = 1:2.02-0.65.el7.centos.2 You could try using --skip-broken to work around the problem ** Found 41 pre-existing rpmdb problem(s), 'yum check' output follows: ``` #### 解决方法: ```bash $ yum install yum-utils $ package-cleanup --dupes $ package-cleanup --cleandupes $ yum update --skip-broken ``` #### 执行更新操作 ```bash $ yum update ``` ``` Packages skipped because of dependency problems: 1:grub2-tools-2.02-0.65.el7.centos.2.x86_64 from base ``` #### 解决方法: ```bash $ yum remove grub2 grub2-common grub2-pc grub2-pc-modules grub2-tools grub2-tools-efi grub2-tools-extra grub2-tools-minimal $ yum install grub2 grub2-common grub2-pc grub2-pc-modules grub2-tools grub2-tools-efi grub2-tools-extra grub2-tools-minimal ```

文章分类: 系统     个人分类: centos/redhat

收藏


0 条评论
按时间正序 按时间倒序